New Posts New Posts RSS Feed: Problem with Object Mapper in German Visual Studio
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Forum LockedProblem with Object Mapper in German Visual Studio

 Post Reply Post Reply
Author
Customer View Drop Down
Senior Member
Senior Member
Avatar
User Submitted Questions to Support

Joined: 30-May-2007
Location: United States
Posts: 260
Post Options Post Options   Quote Customer Quote  Post ReplyReply Direct Link To This Post Topic: Problem with Object Mapper in German Visual Studio
    Posted: 30-May-2007 at 5:36pm
 can't get the “IdeaBlade Object Mapper” menu entry to show up in VS2005 (German Edition).

I have already tried the measures in the installation guide, but I can't get it to work. I located the add-in in the folder

 
 
The Object Mapper Installer shows an error message that shows:

Destination folder missing: C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\MSEnvShared\Addins.

Note that the Object Mapper Installer tries to use the German folder name ("Anwendungsdaten" instead of "Application Data"), while the original Setup obviously installed in "Application Data" (both use the German "Dokumente und Einstellungen", though).

I also tried to rename the add-in in the folder where I found it, restarted VS, renamed again and restartet VS again, to no avail. It seems to me that the Add-In might be looking for a "Tools" menu, but in the German version this menu is named "Extras".

Back to Top
IdeaBlade View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 30-May-2007
Location: United States
Posts: 353
Post Options Post Options   Quote IdeaBlade Quote  Post ReplyReply Direct Link To This Post Posted: 30-May-2007 at 5:50pm

It appears that the InstallShield installer and the Object Mapper Installer have different opinions as to where the Add-Ins are located. The Object Mapper Installer uses the registry, so we believe it has the correct opinion. The InstallShield-based Installer knows about certain "Special Folders" and knows the "Internationalized names" for these folders. Unfortunately, it doesn't have any "Special Folder" for the "Application Data" folder underneath "All Users". Instead, it "hard-wires" the name to "Application Data" underneath the "Special Folder" for "All Users".

My guess is that you may be able to fix your problem by copying the three files: (IdeaBlade.DevTools.Orm.AddIn, IdeaBlade.DevTools.Orm.AddIn.dll, Visual.Studio.CommandBars.dll ) from the path that contains "Application Data" to the path that contains "Anwendungsdaten". If this doesn't work, let me know. If necessary, we can build you a new setup.exe.

The fix will require me to add a custom action to install/uninstall the files in the correct location. Since we don't have a version of a German XP or a German Visual Studio, I am wondering if you could help me test the installation.

Back to Top
Customer View Drop Down
Senior Member
Senior Member
Avatar
User Submitted Questions to Support

Joined: 30-May-2007
Location: United States
Posts: 260
Post Options Post Options   Quote Customer Quote  Post ReplyReply Direct Link To This Post Posted: 30-May-2007 at 5:52pm

I've tried again to get the ORM menu entry and now I succeeded, through the "Customize - Addins" function, dragging the entry to the menu. The situation regarding the directories is as follows:

Although my OS and my VS2005 software are German, the proper directory for the Visual Studio plugins is obviously

C:\Dokumente und Einstellungen\All Users\Application Data\Microsoft\MSEnvShared\Addins.

Note that this is mixed: "Dokumente und Einstellungen" is German, "Application Data" is not.

The "hard-wired" name in Installshield seems to be right.

In the folder

C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft

(the "fully" German version), there is no folder "MSEnvShared". I created it and the content therein, but it didn't seem to have any impact. I deleted it again, and the ORM still works.

Back to Top
IdeaBlade View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 30-May-2007
Location: United States
Posts: 353
Post Options Post Options   Quote IdeaBlade Quote  Post ReplyReply Direct Link To This Post Posted: 30-May-2007 at 5:53pm

Thank you so much for your information. It is very helpful.

We’re surprised by what you found. We had thought that the Germanized folder name would be the correct one, but your experiments show that this is not the case. It makes me suspect that this is really a Microsoft bug.

This means that what I need to change is the Object Mapper Installer, not the Installer.

It is interesting that you succeeded through the "Customize - Addins" function, dragging the entry to the menu. This workaround was discovered when I was working with another customer. This customer was also from Germany!!!

We'll add the fix to the Object Mapper Installer.


Back to Top
davidklitzke View Drop Down
IdeaBlade
IdeaBlade
Avatar

Joined: 14-Jun-2007
Posts: 715
Post Options Post Options   Quote davidklitzke Quote  Post ReplyReply Direct Link To This Post Posted: 14-Oct-2007 at 6:20pm

In late July, we discovered a bug in our installation script that caused DevForce installations to always hang on certain Vista machines (such as Sony VAIO laptops).  The fix for this bug turned out to have an unintended side effect that is now causing Object Mapper problems for customers who have installed a German version of Windows XP.  The rest of this post documents the cause of this problem and how to correct it.

The side effect of the aforementioned bug fix is that it installs the ORM files in C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\MSEnvShared\Addins instead of in C:\Dokumente und Einstellungen\All Users\Application Data\Microsoft\MSEnvShared\Addins.  From a registry standpoint, this is the correct location, but if you have read the previous posts in this thread, you will understand that this will break the operation of the Object Mapper.

I did research this matter and found that the reason that Visual Studio uses a hard coded "English name" for "Application Data" instead of an internationalized name is due to a bug in Visual Studio.

http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=109056

There is a known bug with the %ALLUSERSPROFILE% value, the next portion of the path, Application Data, is localized on some non-English locales, but we hard code to Application Data. The fix for this is to add your own value to the registry to point to the directory you install your Add-in into.

This bug will be fixed for the next release of Visual Studio.

The recommended fix for getting the Object Mapper working on machine with a German OS is to add an "Add-in File Path". 

This is what it looks like using a German Visual Studio.

Open up “Extras” menu in Visual Studio 2005, and select “Optionen”. 

In “Optionen” form.  Select “Add-in/Makrosicherheit” from “Umgebung”. 
 
Select “Hinzufugen”.
 
Navigate to “All Users” directory, then “Anwendungsdaten”, then “Microsoft”.
 
then “MSEnvShared”, then “Addins”.  Press “OK” button.  This will add the correct search directory for the DevForce ORM Addin.
 


Edited by davidklitzke - 14-Oct-2007 at 6:39pm
Back to Top
dmaya View Drop Down
Newbie
Newbie
Avatar

Joined: 26-Mar-2009
Location: Hostalets de Ba
Posts: 3
Post Options Post Options   Quote dmaya Quote  Post ReplyReply Direct Link To This Post Posted: 08-Sep-2009 at 5:39am
Hello,

The Spanish Directory is :

C:\Documents and Settings\All Users\Datos de programa\Microsoft\MSEnvShared\AddIns

Hope it helps

David
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down