New Posts New Posts RSS Feed: Fail to connect with remoting
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Fail to connect with remoting

 Post Reply Post Reply
Author
Dominique View Drop Down
Groupie
Groupie
Avatar

Joined: 28-Jun-2007
Location: Norway
Posts: 44
Post Options Post Options   Quote Dominique Quote  Post ReplyReply Direct Link To This Post Topic: Fail to connect with remoting
    Posted: 18-Aug-2009 at 2:35am
Hi,

Our app: Dotnet winapp using remoting through a BOS
Customer is successful in using our application from one location but won't manage to use it from an other location.

User get the following error when starting app:
Unable to connect to http://<server address>:80/booking/PersistenceServer.rem. The server or internet connection may be down.

Do you have a clue of what could be wrong
  • on my side
  • on their side
If error is on their side: do you have any clue I could give my customer for finding the source of the error.
On a general plan, do you know if Proxy-servers on an intranet can cause issues for an app using dotnet-remoting (and devforce remoting specially)


Dominique
Back to Top
JoshO View Drop Down
IdeaBlade
IdeaBlade
Avatar

Joined: 09-May-2007
Location: United States
Posts: 87
Post Options Post Options   Quote JoshO Quote  Post ReplyReply Direct Link To This Post Posted: 18-Aug-2009 at 2:22pm
.NET Remoting requires "transparent" or "pass-through" authentication when network communication is directed through a proxy server. If the user is prompted to enter credentials when accessing the Internet, then you know the proxy server is not currently configured to use a pass-through authentication such as Windows Authentication or Active Directory.
 
Typically a Windows operating system is configured to use a proxy server for Internet access by using Internet Explorer's "Connections" settings (described below) or you can configure the client application's IdeaBlade.ibconfig file.
 
If Internet Explorer is already configured with the proxy settings, then you donít have to do anything since .NET Remoting inherits these settings. You can check the proxy information in Control Panel > Internet Options. An "Internet Properties" window opens, then click on the "Connections" tab, click the "LAN Settings..." button, check the "Use a proxy server..." checkbox and enter the computer name (or IP address) of the proxy server and the port used for outbound Internet traffic (http).
 
If you do not use the IE method, then there are 2 elements of the IdeaBlade.ibconfig file that must be used: <ProxyName> and <ProxyPort>. In the graphic below, I have circled the proxy elements in a blank ibconfig. You would replace "ServerName" with the computer name of the proxy server and you enter the port number configured on the proxy server that accepts client connections to the Internet for http traffic. Typically the port is 80 or 8080, but a custom port could be used instead. Of course, the rest of the standard "Remoting" elements need to be configured as well (I have not done that in the screenshot below):
 
 
Back to Top
Dominique View Drop Down
Groupie
Groupie
Avatar

Joined: 28-Jun-2007
Location: Norway
Posts: 44
Post Options Post Options   Quote Dominique Quote  Post ReplyReply Direct Link To This Post Posted: 18-Aug-2009 at 10:53pm
Hello Josh

Thansk for the head up, I'll check this out

Dominique
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down