New Posts New Posts RSS Feed: Random problem
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Forum LockedRandom problem

 Post Reply Post Reply
Author
nowol View Drop Down
Newbie
Newbie


Joined: 08-Jul-2009
Posts: 5
Post Options Post Options   Quote nowol Quote  Post ReplyReply Direct Link To This Post Topic: Random problem
    Posted: 08-Jul-2009 at 12:55pm
Hi,

once in a while we receive an error saying "This row has been removed from a table and does not have any data" but we are unable to reproduce the problem...it only happen about once or twice a week.  From the call stack we can see that it is DefForce that is causing the exception.  Do you know how we can fix this ?

Thanks !

This is the call stack that we log:

-------------------------8<-----------------------------
Timestamp: 7/8/2009 3:20:37 PM
Message: userId = 7726 Message = Informator Web Services Exception!
Stack =System.Data.RowNotInTableException: This row has been removed from a table and does not have any data.  BeginEdit() will allow creation of new data in this row.
   at System.Data.DataRow.GetDefaultRecord()
   at System.Data.DataRow.get_Item(DataColumn column)
   at IdeaBlade.Persistence.Entity.GetColumnValue(DataColumn pColumn)
   at IdeaBlade.Persistence.Entity.GetColumnValue(DataColumn pColumn, Type pOutputType, Boolean pAllowNull)
   at matic.Domain.EmployeeEvaluationDataRow.GetStateImpl() in e:\matic\Domain\matic.Domain\EmployeeEvaluationDataRow.cs:line 903
   at matic.Domain.EmployeeEvaluationDataRow.get_State() in e:\matic\Domain\matic.Domain\EmployeeEvaluationDataRow.cs:line 893
   at matic.Domain.EmployeeEvaluation.get_EvaluationStatus() in e:\matic\Domain\matic.Domain\Persistable\Person\matic.Domain.EmployeeEvaluationClasses.cs:line 97
   at matic.Orchestration.EvaluationSkillEditor`1.get_IsEditable() in e:\matic\Orchestration\matic.Orchestrator\Editor\matic.Domain.Orchestration.SpecializedEditors.cs:line 235
   at matic.UIP.Controllers.UserController.InitializeForm(UILocation actualLocation) in e:\matic\PresentationTier\Common\matic.UIP\Controllers\matic.UIP.UserController.cs:line 129
   at matic.UIP.UIPController.Initialize(IMainOrchestrator mainOrchestrator, UILocation actualLocation) in e:\matic\PresentationTier\Common\matic.UIP\matic.UIP.ControllerBase.cs:line 259
   at matic.Web.Services.Informator.IsEmployed(String keyRepresentation) in e:\matic\ui\Services\Informator.asmx.cs:line 205
Category: Exception
Priority: 0
EventId: 0
Severity: Critical
Title:
Machine: IPDMCZ0133MIA
Application Domain: /LM/W3SVC/181076520/Root/maticnet-1-128915374145085000
Process Id: 4012
Process Name: c:\windows\system32\inetsrv\w3wp.exe
Win32 Thread Id: 3704
Thread Name:
Extended Properties:
-------------------------8<-----------------------------
Back to Top
nowol View Drop Down
Newbie
Newbie


Joined: 08-Jul-2009
Posts: 5
Post Options Post Options   Quote nowol Quote  Post ReplyReply Direct Link To This Post Posted: 08-Jul-2009 at 1:59pm
I should add that we are using DevForce 3.6.3.4 with IIS6 on Windows 2003 (I didn't saw anything in the new versions that fix this problem).
Back to Top
eileenv View Drop Down
IdeaBlade
IdeaBlade
Avatar

Joined: 15-Jun-2007
Location: United States
Posts: 68
Post Options Post Options   Quote eileenv Quote  Post ReplyReply Direct Link To This Post Posted: 30-Jul-2009 at 10:54am
Can you give any information as to the steps that may have led to the exception getting thrown?
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down